Makerere University

Enter a keyword or two into the search box above and click search..

Pretty permalinks and .htaccess 404 Not Found Errors

You are here

If you have enabled Permalinks on your Wordpress website and have started getting 404 errors on your pages, try the following:

  1. Ensure that your site has a .htaccess file in its root director and that its writable (change it to 666, re-enable the permalinks, test if its its working and eventually change it 644 for security purposes)
  2. If you have tried the above option and it has failed, then edit your vhosts apache config file:

sudo nano /etc/apache2/sites-available/

<Directory "/path/to/your/app">
  Options FollowSymLinks
  AllowOverride All
  Order allow,deny
  Allow from all